Unable to install Microsoft ASP.NET 2.0 AJAX Extensions

The full error message is:

Microsoft ASP.NET 2.0 AJAX Extensions 1.0 requires the .NET Framework 2.0 of .NET Framework 3.0 The .NET Framework installed can be found on the website (http://go.microsoft.com/fwlink/?linkID = 76097). Please install a compatible version of the framework and try again.

Yes, this is outdated stuff but when working on legacy ASP.NET applications, you may be required to install ASP.NET 2.0 AJAX Extensions.

If you are working on Windows 7 x64 or later, this is probably a permissions issues. You are probably not logged in to your box as Administrator. You will, therefore, have to run the ASPAJAXExtSetup.msi as Administrator as follows:

  1. Start a command prompt as administrator.
  2. CD to the directory containing the installer
  3. Type the command msiexec /i ASPAJAXExtSetup.msi to run the installer.

This should run the installer, adding a folder C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET 2.0 AJAX Extensions\v1.0.61025 with associated libraries.

Credit to some answers to this question from here.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s